Google Maps - Creating a Big Image Montage from Map Tiles

From NoskeWiki
Jump to: navigation, search

About

NOTE: This page is a daughter page of: Google Maps


Every so often I want to create a nice big Google Map image. For a small image I can just screenshot, but beyond a certain size it gets annoying to take multiple screenshots and stitch them together manually in Photoshop! Here's the process I've used to download tiles and stitch them together.

There should be some tools on the web which can do this as well, but I haven't found any reliable ones yet, so I run this process myself.


Google Maps - Creating a Big Image Montage from Map Tiles

To get tiles from Google maps into one big huge montage image:

Step 1: Identify min/max tile values using Chrome

  • Open Chrome.
  • Go to: Google Maps, then click the question make icon bottom right "Return to classic Google

Maps".

  • Select satelitte or map (which one you prefer) and go to the zoom level you want.
  • Determine the range of tiles you need:
    • Press [ctrl]+[shift]+[c] and click on the top left tile you want.... it should show you are URL like:
    • Write down the x, y and z values for the minimum value tile, where x and y is the tile coordinate, and z is zoom level (higher is closer).
    • Press [ctrl]+[shift]+[c] again and click on the bottom right tile... write down the new x and y again for the maximum tile value.
    • You should now have:
      • min tile: x=21070, y=50810
      • max tile: x=21110, y=50840
      • zoom: z=17

Step 2: Create a html with a grid of tile links using Spreadsheet

  • Open Google Spreadsheet or Microsoft Excel.
    • Create a new sheet.
    • Enter "21070, 21071, ..., 21110" along top row, starting cell B1.
    • Enter "50810, 50811, ..., 50840" down first column, starting cell A2.
      • TIP: Just enter the first two, select them and drag the bottom right icon across to complete sequence.
    • Enter the following forumulae into B2:


Step 3: Download all tiles with Firefox's "Download them All" tool

  • Open Firefox.
    • Install "DownloadThemAll" by going Tools > Add Ons, then search for "DownloadThemAll" and install.
    • Open "tiles.html" via File > Open.
    • You should see hyperlinks for all tiles appear (if you click on one you'll see the tile).
    • Go: Tools > DownloadThemAll... then make sure "All Files" is selected, output to a "tiles/" folder on your desktop, and then click "Start".
    • Wait for all tiles to load, and click a couple to see it worked.


Step 4: Stitch tiles together using a script in Photoshop

  • Open Photoshop.
    • WARNING: If files are saved to PNG, they are usually a strange non 8-bits-per-channel PNG which don't resize in Photoshop without re-saving... hence the next step is necessary:
      • If files were saved as PNG, they are sometimes not writable... meaning you will probably have to run the "export_folder_to_png.jsx" script Adobe Photoshop - Scripts for Image Type Conversions to turn all your dodge .png files into writable 8-bit .png files (and delete all the old ones) before the next step.
    • Create then run the "combine_tiles_into_montage.jsx" script from Adobe Photoshop - Scripts Related to Montaging and it should stitch all your tiles into a single big montage. Hooray!
    • Save/export the resulting big montage with as your desired file type.


Links